Mikrotik – menggunakan Squid sebagai Web Proxy sehingga lebih optimal ( Ipcop )


Sesuai dengan judulnya maka akan saya share cara mengoptimalkan Squid Proxy ( dengan menggunakan Ipcop, Tutorial instal Ipcop bisa anda lihat disini ) beserta Mikrotik sebagai pembagi bandwidthnya.

Buat dulu setingan IP address untuk Mikrotik serta Proxy :
Kita contohkan :
– Modem : 192.168.1.1
– Lokal ( mikrotik ) : 192.168.2.1
– Proxy : 192.168.3.1 ( mengarah ke mikrotik )
– IP Ipcop : 192.168.3.2 ( green ), 192.168.3.3 ( Red ), Khusus untuk red jangan di colokkan kabel lan alias biarkan kosong
– Ip Client : 192.168.2.0/24

ok di ipcop disetting dulu bahwa web proxynya jalan di port 8080 ( gunakan Advproxy supaya lebih optimal ) <= terserah anda aktifkan cachenya misal 15M atau 15000

sekarang kita masuk ke mikrotiknya:

/ ip address
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 \
   interface=speedy comment="" disabled=no
add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 \
   interface=lokal comment="" disabled=no
add address=192.168.3.1/24 network=192.168.3.0 broadcast=192.168.3.255 \
   interface=proxy comment="" disabled=no

setting route:
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10 \
   comment="" disabled=no

Setting Dns : ( sesuaikan dengan dns provider internet anda )
/ ip dns
set primary-dns=203.130.193.74secondary-dns=202.134.0.155 \
   allow-remote-requests=no cache-size=2048KiB cache-max-ttl=1w

setting nat:
/ip firewall nat add chain=dstnat protocol=tcp dst-port=81 action=dst-nat to-address=192.168.3.2 \
to-port=8080 comment=Untuk-IpCop
/ip firewall nat add chain=dstnat protocol=tcp dst-port=445 action=dst-nat to-address=192.168.3.2 \
to-port=8080 comment=Untuk-Https-IpCop
/ip firewall nat add chain=dstnat protocol=tcp dst-port 80 src-address=!192.168.3.0/24 \
action=dst-nat to-address=192.168.3.2 to-port=8080
/ip firewall nat add chain=srcnat out-interface=speedy action=masquerade

SETTING MANGLE PROXY:

PROXY HIT :

/ip firewall mangle add chain=forward protocol=tcp action=mark-connection new-connection-mark=Hit \
in-interface=proxy out-interface=lokal passthrough=yes comment=Proxy-Hit
/ip firewall mangle add chain=forward protocol=tcp action=mark-packet new-packet-mark=Hit in-interface=proxy \
out-interface=lokal passthrough=no connection-mark=Hit

Download From Lan :

/ip firewall mangle add chain=forward protocol=tcp action=mark-connection \
new-connection-mark=Down-Lan in-interface=speedy out-interface=lokal passthrough=yes comment=Download-From-Lan
/ip firewall mangle add chain=forward protocol=tcp action=mark-packet new-packet-mark=Download-Lan in-interface=speedy \
out-interface=lokal passthrough=no connection-mark=Down-Lan

Download From Proxy :

/ip firewall mangle add chain=forward protocol=tcp action=mark-connection \
new-connection-mark=Down-Proxy in-interface=speedy out-interface=proxy passthrough=yes comment=Download-From-Proxy
/ip firewall mangle add chain=forward protocol=tcp action=mark-packet new-packet-mark=Download-Proxy in-interface=speedy \
out-interface=proxy passthrough=no connection-mark=Down-Proxy

Nah segitu aja dulu. Silahkan di coba browsing. Dan khusus untuk Queue nya silahkan pilih yang simpel atau Tree.

Di lain kesempatan akan saya berikan contoh queue tree untuk Proxy
Pos ini dipublikasikan di Jaringan dan tag . Tandai permalink.

3 Balasan ke Mikrotik – menggunakan Squid sebagai Web Proxy sehingga lebih optimal ( Ipcop )

  1. bobbi berkata:

    assalamualaikum
    mas itu tutor diatas kok pada saat ada client browsing kok kena ke download proxy ya mas, trus untuk browsing avg rate nya 0 aja mas, gmana tuh mas, mas kalo bisa kasi script lengkap donk mas buat aplikasi saya mas, trim’s mas
    bls email saya ya mas

    • nananktw berkata:

      waskum…saya sarankan proxy externalnya pakek ubuntu aja mas..dijamin maknyus internete sampean…klo ip cop…susah di buat cache dinamik conten

  2. gmn tuh mas carax gabung mikrotik sama ubuntu tolong tutorialx

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s